As we announced in a previous article we are moving to Symfony. Therefore Symfony will be a dependency and we have to reflect their minimum requirements as of the 3.5-release.
Not that much has changed, most importantly the PHP version, which has to be at least 5.3.3. The other extra requirements are the JSON-extension and PCRE-extension. This was already the case, even though it was not being checked if they were available.
The full list of minimum requirements:
- PHP 5.3.3 or higher
- The following PHP extensions should be installed and enabled: cURL, libxml, DOM, SimpleXML, SPL, PDO (with MySQL driver), mb_string, iconv, GD2 graphics library, json, PCRE.
- MySQL 5.0 or higher
- Apache 2.0 with .htaccess, mod_rewrite, mod_expires (optional but recommended), mod_deflate (optional) enabled.